486 Revival

Aug 21, 2021 | Computing

As part of my want to recreate some of my earliest machines growing up I thought I would go back to the very first one, a 486. It was a hand me down desktop style with Windows 95 on it. I don’t think I had it long before I upgraded to a Pentium 100/120.

Retro collection day pickup

It wasn’t really going to be a reality until I saw a pair of machines at the retro tech sale in Onehunga just before the very first covid lockdown. Sadly I couldn’t open them up properly to look inside other than seeing they had 486 chips inside. Once I got them home as well as some ram I could open them up and see the horror that awaited me. Both boards had bad battery damage and were completely non functional, at least the cases, power supplies, floppy drives and expansion cards were all in working order. Lucky for me, one of my fellow retro gamers had found some 486 boards at the same sale that he gifted me to get me up and running with a 486, as well as a VLB video card.

Bulk chip pickup

As a bit of a fluke purchase I spotted a listing for 3kg’s of CPU’s. Everything from Pentiums, 486’s, Pentium Overdrives and more. A lot of the chips had bent pins as they had clearly been sitting in a box/bin for years. It wasn’t overly cheap but I managed to remove some of the double ups and get all my money back, essentially making my ones free. These chips will give me a good base to test from.

Round 1 of repairs

The first round of testing went so so. A lot of the boards that I had were battery damaged. One of the the hardest parts of diagnosing these boards was actually finding the manuals to get the jumper settings for each board. Some of them I just couldn’t find anything on them so I had to resort to putting a less ideal chip in them to see if I got any post codes come up, if only to get a model number or something to be able to look up. I did managed to get 4 boards going on this round.

Chip damaged

I did manage to track down a fairly unusual issue. Upon closer inspection of one of the boards I was given from my mate, the main chip was actually not connected to the board at all, and on even closer inspection, it looked like it had been hit but something and bent a few pins/ripped some traces. I did attempt to reconnect these pins but had no success getting the board to work.

no images were found

DOS Setup

Once I had two boards working for the two cases I picked up I loaded up my DOS image and got everything working.

no images were found

Repairs Round 2

About 8 months after a few other projects I decided to revisit the boards and see if I had learnt anything and if I could get any more going, or at a minimum get rid of the ones that I couldn’t get working. Turns out I did learn something. Out of this batch I managed to get 5 boards going. Some of the issues I had were:

  • no power on some of the rails ( bad solder joints )
  • wrong ram used ( more on that below )
  • Finding a CPU that worked with the board. I found that the IBM DX2 ( Cyrix chip ) seemed to be the most compatible for some reason. Once I got it booted I could then take note of the board/bios to do more googling
  • bad keyboard chip
  • Missing traces that I missed the first time around. This time I had a digital microscope to be able to get a much better look at the damaged traces.
  • corroded pins on bios and other chips which I fixed by tinning them with solder.

So it was a good second round of repairs. Sadly I still had 3 boards that showed no signs of life. They all showed power, and the bios read good but the reset line just stayed high and the post code reader showed 00. Something that I found out this time around was that the 4 digit post code readers actually are just two 2 digit readers, with the ones on the left being the current code and the ones on the right being the previous code. This made diagnosing it much easier as I could actually look up the code and know what the issue was ( like things in the 80’s being keyboard related and low error code being ram issues ).

Ram Discovery

One likely obvious thing I discovered this time around which was likely a big part of the success was that there is actually two types of 72pin SIMMS. EDO and FPM and that ‘most’ 486 boards only support FPM modules. Even externally they are not easy to tell apart but I saw something on a forum that if the part number of the chips ends a 0 (zero) it will likely be FPM and if it ends in a letter it will likely be EDO, something that checked out for all the modules that I had. I had no luck with the 30pin modules, which was likely a jumper issue and a lack of manuals available.

no images were found

Final working boards and machines

So out of the full set of 10 boards I ended up with 7 that work in some way or another, my base level is, if it posts to a bios screen I consider it a success for now. The 7 boards are:

  • A Gigabyte GA-486VS with an Intel DX2-50, 16MB of ram and 256k of cache
  • An MB-8433UTC PCI board with an AMD DX4-100, 32MB ram and 256k of cache
  • An unknown OPTI chip board with a DX4-100, 16mb of ram and 256k of cache
  • An HD4077D board with an Intel 486 DX2-66, 8mb of ram and 256k of cache
  • An AL 486 board with a DX4-100, 64mb of ram and 256k of cache
  • An unknown ALI M428/M431 based board with an IBM Lightning DX2-50, 16MB ram, no cache and still has a keyboard detection error
  • An MB-4DUVC-P-AB board with a DX4-100, 64mb of ram, 256k of cache

The two full machines are both loaded with my DOS Image:

  • The small tower with the MB-4DUVC-P-AB board, DX4-100, 64mb of ram, 256k of cache, Creative Vibra 16 ( with CD Drive on the IDE header ), Dual Compact Flash to IDE adapters, I/O card,1.44mb 3.5″ floppy, 1.2mb 5.25″ floppy, and a Western Digital WDC WD90C33-22 VLB video card
  • The desktop with the MB-8433UTC PCI board, AMD DX4-100, 32MB ram, 256k of cache Soundforge Vibra 16S, ISA Floppy Disk Controller by Sergey Kiselev, 1.44mb 3.5″ floppy, XT-IDE Rev 2 board and a S3 Virge Trio64+ PCI video card.

no images were found

Final non-working machines

As for the non working boards, I actually got one of them working in the photo, so I am left with two PCI boards and another MB-4DUVC-P-AB with the bent pins/traces. These showed no signs of life and with 7 others I figured i’d move past them and onto other projects.

no images were found

0 Comments

Submit a Comment

Your email address will not be published. Required fields are marked *